Não foi possível iniciar o serviço PostgreSQL Database Server 8.3 em Computador local. Erro 1069:  XML
Índice dos Fóruns » Java Básico
Autor Mensagem
EuclidesFilizola
Virtual Machine Man
[Avatar]

Membro desde: 21/09/2006 12:38:54
Mensagens: 511
Offline

Não foi possível iniciar o serviço PostgreSQL Database Server 8.3 em Computador local. Erro 1069: Não foi possível iniciar o serviço devido a uma falha de logon. Boa tarde a todos. Eu instalo o PostgreSQL e depois que o computador reinicia. Ele não conecta mais. Apenas quando eu instalo. Se eu reiniciar a máquina. BUF !! ... já era ¬¬.... ae alguém pode me dar alguma luz ?? Agradeço Antecipadamente.

This message was edited 1 time. Last update was at 04/03/2009 13:32:23


"Inteligencia é a faculdade de fazer objetos artificiais... especialmente ferramentas para fazer ferramentas"
[MSN]
rogeriuslima
JavaChild
[Avatar]

Membro desde: 27/02/2008 15:00:01
Mensagens: 130
Offline

Seu sistema operacional é windowns ou linux?
Se for windowns o problema é que somente o usuario postgres (ou outro configurado) pode iniciar o servidor.
só não lembro como configurar o usuario no windowns.

P.S: quando eu falo usuario eu tô falando do usuario do sistema operacional, não é o usuario do banco.

This message was edited 1 time. Last update was at 04/03/2009 14:18:38


Sexo é sujo? Só quando feito da maneira correta. (Woody Allen)
[MSN]
EuclidesFilizola
Virtual Machine Man
[Avatar]

Membro desde: 21/09/2006 12:38:54
Mensagens: 511
Offline

meu sys. é windows.

"Inteligencia é a faculdade de fazer objetos artificiais... especialmente ferramentas para fazer ferramentas"
[MSN]
wbdsjunior
GUJ Ranger
[Avatar]

Membro desde: 16/04/2008 13:48:08
Mensagens: 992
Localização: Indaiatuba/SP
Offline

o que o amigo rogeriuslima quis dizer é que o problema deve estar na configuração do serviço do postgresql.

vá em "Iniciar/Configurações/Ferramentas Administrativas/Serviços", procure pelo serviço do postgresql, clique com o botão direito do mouse sobre o seviço e clique em "Propriedades", clique na aba "Logon" e selecione a opção "Conta do Sistema Local" e veja se resolve o problema.

abraço.

She loves me

http://lmgtfy.com
rogeriuslima
JavaChild
[Avatar]

Membro desde: 27/02/2008 15:00:01
Mensagens: 130
Offline

Então cara, eu não me lembro muito bem como que é, mais se não tô enganado, no win quando vc instala o postgres em um dos passos ele vai perguntar se vc quer instalar o banco como um serviço e qual usuario vai poder startar o serviço.
Esse usuario não pode ser um administrador do sistema operacional, ele te sugere o usuario postgres que depois ele vai criar pra vc.
E mais um detalhe, os diretorios do postgres tem que ter permisão de leitura e escrita para este usuario, e só pra ele (eu acho ).
E por último tem que por uma senha para o usurio postgres.

Sexo é sujo? Só quando feito da maneira correta. (Woody Allen)
[MSN]
EuclidesFilizola
Virtual Machine Man
[Avatar]

Membro desde: 21/09/2006 12:38:54
Mensagens: 511
Offline

galera.. já era.. reinstalei o postgreSQL.. por HOJE ( 04 / 03 / 09 ) ... ele está funcionando... vamos vê amanhã se vai continuar funcinando.. toda vez q eu volto no outro dia... da BUF.. ! mas valeu pela ajuda galera.. vamos esperar até amanhã... se continuar dando pro.. eu aviso a vcs .. abraços

"Inteligencia é a faculdade de fazer objetos artificiais... especialmente ferramentas para fazer ferramentas"
[MSN]
rodrigo.bossini
GUJ Master
[Avatar]

Membro desde: 01/07/2008 20:59:17
Mensagens: 1088
Offline

wbdsjunior wrote:o que o amigo rogeriuslima quis dizer é que o problema deve estar na configuração do serviço do postgresql.

vá em "Iniciar/Configurações/Ferramentas Administrativas/Serviços", procure pelo serviço do postgresql, clique com o botão direito do mouse sobre o seviço e clique em "Propriedades", clique na aba "Logon" e selecione a opção "Conta do Sistema Local" e veja se resolve o problema.

abraço.


Valeu cara, essa resposta sua caiu do céu pra mim.

Abraços.

http://www.rodrigobossini.com.br/
EuclidesFilizola
Virtual Machine Man
[Avatar]

Membro desde: 21/09/2006 12:38:54
Mensagens: 511
Offline

wbdsjunior wrote:o que o amigo rogeriuslima quis dizer é que o problema deve estar na configuração do serviço do postgresql.

vá em "Iniciar/Configurações/Ferramentas Administrativas/Serviços", procure pelo serviço do postgresql, clique com o botão direito do mouse sobre o seviço e clique em "Propriedades", clique na aba "Logon" e selecione a opção "Conta do Sistema Local" e veja se resolve o problema.

abraço.


muito bom.. sua idéia funciona.. Obrigado. Agora me explica, o porquê disso ? Porque que preciso marcar , e não do jeito que eu instalei funciona?

"Inteligencia é a faculdade de fazer objetos artificiais... especialmente ferramentas para fazer ferramentas"
[MSN]
thingol
Moderador

Membro desde: 29/07/2004 16:10:13
Mensagens: 17572
Offline

Pergunte ao pessoal que criou o instalador do PostgreSQL.
Como você deve ter percebido, esse tipo de coisa é bastante chato (devido ao número de detalhes chatos relativos ao sistema operacional) e não muito valorizado pelo pessoal que cria aplicações open-source.
Como um usuário "power" pode consertar esse problema (setando corretamente a identidade do usuário que inicia o serviço Windows) com relativa facilidade, eles não se preocupam em deixar isso à prova de leigos.
[WWW]
 
Índice dos Fóruns » Java Básico
Ir para:   
Powered by JForum 2.1.8 © JForum Team