Botao acessando link em jsp [RESOLVIDO]  XML
Índice dos Fóruns » Desenvolvimento Web
Autor Mensagem
satangoss
JavaGuru
[Avatar]

Membro desde: 08/03/2009 11:24:35
Mensagens: 207
Offline

Olá pessoal tenho uma dúvida simples mas que não estou conseguindo fazer, é o seguinte:
tenho uma variavel em JSP que tem o link de um documento que é atribuido dessa forma:


atraves dessa váriavel gero um link para esse documento assim:





gostaria de fazer a mesma coisa mas acessando através de um button assim:



mas não esta dando certo alguém tem alguma dica de como fazer ou o que está errado?
Abraço

This message was edited 1 time. Last update was at 15/10/2012 13:07:30

[WWW]
ayslanms
JavaTeenager

Membro desde: 12/01/2011 13:39:17
Mensagens: 174
Offline

Utiliza o type button e o script window.location.href:


This message was edited 2 times. Last update was at 15/10/2012 09:56:44


xpert-framework: http://showcase.xpertsistemas.com.br
Novidades sobre tecnologia: http://www.xpertsistemas.com.br/blog
[WWW]
satangoss
JavaGuru
[Avatar]

Membro desde: 08/03/2009 11:24:35
Mensagens: 207
Offline

ayslanms wrote:Utiliza o type button e o script window.location.href:




Não acontece nada igual no meu código.
[WWW]
ayslanms
JavaTeenager

Membro desde: 12/01/2011 13:39:17
Mensagens: 174
Offline

Talvez seu objeto url não esteja preenchido, faz um teste ai:


xpert-framework: http://showcase.xpertsistemas.com.br
Novidades sobre tecnologia: http://www.xpertsistemas.com.br/blog
[WWW]
satangoss
JavaGuru
[Avatar]

Membro desde: 08/03/2009 11:24:35
Mensagens: 207
Offline

ayslanms wrote:Talvez seu objeto url não esteja preenchido, faz um teste ai:


Também já havia testado dessa forma mas do mesmo jeito não acontece nada.
[WWW]
ayslanms
JavaTeenager

Membro desde: 12/01/2011 13:39:17
Mensagens: 174
Offline

Muito estranho isso aí.
Tenta fechar a tag input:



Não vejo motivo para esse código não funcionar, tenta salvar em um html simples para você ver o resultado.
Caso você queira testar pode usar esse link http://www.draac.com/htmltester.html e cola esse input ai.
Verifica se o javascript está habilitado também.

xpert-framework: http://showcase.xpertsistemas.com.br
Novidades sobre tecnologia: http://www.xpertsistemas.com.br/blog
[WWW]
satangoss
JavaGuru
[Avatar]

Membro desde: 08/03/2009 11:24:35
Mensagens: 207
Offline

ayslanms wrote:Muito estranho isso aí.
Tenta fechar a tag input:



Não vejo motivo para esse código não funcionar, tenta salvar em um html simples para você ver o resultado.
Caso você queira testar pode usar esse link http://www.draac.com/htmltester.html e cola esse input ai.
Verifica se o javascript está habilitado também.

Estou enviando esse código embutido em mensagem por email, estou testando clicando no botão no cliente de email, é possível que seja alguma coisa relacionada a isso?
[WWW]
ayslanms
JavaTeenager

Membro desde: 12/01/2011 13:39:17
Mensagens: 174
Offline

Com certeza sim. Não é aconselhável enviar javascript em conteúdo de email (geralmente são bloqueados), utilize links normais no lugar de button ou submit.

xpert-framework: http://showcase.xpertsistemas.com.br
Novidades sobre tecnologia: http://www.xpertsistemas.com.br/blog
[WWW]
satangoss
JavaGuru
[Avatar]

Membro desde: 08/03/2009 11:24:35
Mensagens: 207
Offline

ayslanms wrote:Com certeza sim. Não é aconselhável enviar javascript em conteúdo de email (geralmente são bloqueados), utilize links normais no lugar de button ou submit.

Beleza era isso mesmo o problema vlw, vou tentar usar css para mostrar o link "parecido" com um botão.

This message was edited 1 time. Last update was at 15/10/2012 13:12:43

[WWW]
 
Índice dos Fóruns » Desenvolvimento Web
Ir para:   
Powered by JForum 2.1.8 © JForum Team