como colocar numeros em ordem crescente?  XML
Índice dos Fóruns » Java Básico
Autor Mensagem
sky
Thread.start()

Membro desde: 01/06/2006 14:38:40
Mensagens: 35
Offline

oi galera !!!!

alguem pode me ajudar:

o usuario tem q digitar 10 numeros. aí eu armazeno esses numeros num vetor e depois os apresento em ordem crescente na tela.

Como fazer isso????
DanielSR
Debugger

Membro desde: 10/09/2006 12:02:04
Mensagens: 61
Offline

Leia todos os dados do usuário e vá armazenando num vetor...

Depois de armazenado no vetor, percorra todo o vetor e compare a posição atual com a posição seguinte, comparando ambas posiçoes e deixando o menor valor na posiçao atual e deixando o maior valor na posiçao seguinte (metodo de ordenação da Bolha)..

Depois é só imprimir

Exemplo: no vetor temos: |5 | 2 | 1 | 6 | 3 |
A ideia é vc verificar todas as posições, de forma que a primeira posição a ser verificada é a primeira...
Vc tem q comprar o vetor[0] com vetor[1].. No nosso exemplo temos que 2 é menor q 5, então temos que:
-criar uma variavel auxiliar que recebe vetor[1]
-armazenar vetor[1] em vetor[0]
-armazenar aux em vetor[1]

Depois vc vai fazendo isso com todas as posições do vetor

Espero que vc consiga fazer o algoritmo agora... Qualquer duvida posta ae

Apesar de tudo, a vida continua...
DanielSR
Debugger

Membro desde: 10/09/2006 12:02:04
Mensagens: 61
Offline

Mandei uma mensagem repetida sem querer... Desculpe, se possivel alguem apague isso para mim...

Apesar de tudo, a vida continua...
andrea laranjeira
Entusiasta Java
[Avatar]

Membro desde: 03/10/2008 10:51:57
Mensagens: 16
Offline

oi galera !!!!

alguem pode me ajudar

eu tenho um exercicio pq tenho um duvido

exercicio uma pergunta la em baixo:

1) Faça um programa para gerar n numero inteiros aleatorios e que imprima os numeros em ordem crescente.

2)Faça um programa para gerar n numero inteiros aleatorios e que imprima os numeros em ordem decrescente.

Como fazer isso???? por favor, faz pra mim ai.

abraçosss pra ti...

This message was edited 1 time. Last update was at 03/10/2008 11:13:24

NataliaOliveira
Thread.start()
[Avatar]

Membro desde: 19/06/2006 20:25:43
Mensagens: 48
Offline

Fazer o seu trabalho é complicado, né?

O Daniel acabou de dizer como é a lógica da situação ali em cima, você só tem que aplicar a idéia pra fazer na ordem crescente e mudar a condição pra fazer na ordem descrescente.

Tente, e qualquer dúvida volte aqui.
:}
thingol
Moderador

Membro desde: 29/07/2004 16:10:13
Mensagens: 17572
Offline


Como fazer isso???? por favor, faz pra mim ai


Você pediu duas coisas antagônicas - uma é "como é que se faz tal coisa", o que induz a imaginarmos que você quer aprender a fazer e que você mesmo vai fazer isso.

Logo depois pediu "por favor, façam para mim", o que induz a imaginarmos que você quer ganhar os pontos da sua lição de casa sem aprender a fazer a tal coisa.

De qualquer maneira, vou fingir que não li que você está pedindo o bolo pronto, com uma cereja em cima.

1) Para gerar números aleatórios, use a classe Random (java.util.Random).
2) Para ordenar esses números, se você quer usar coisas prontas, pode usar a classe java.util.Arrays, método sort. Ele põe em ordem crescente; para ficarem em ordem decrescente, pegue os números em ordem crescente e chame java.util.Arrays, método reverse. Se não quer as coisas prontas, então siga a sugestão do Daniel e use o método de "bubblesort".
[WWW]
GALACTUS
Java Ninja
[Avatar]

Membro desde: 18/09/2008 08:32:54
Mensagens: 259
Localização: Sankt Paulus Stadt
Offline

BOM DIA GALERAAAAA.

Ei Andrea Laranjeira, primeiramente quero lhe dizer que você é um belo pé de laranja com belas laranjas.

Segundo, meu anjo, você tem que tentar fazer seus trabalhos se não você será igual eu, preguiçoso e fadigoso.

Olha, tente fazer esses programinhas e a hora que você não conseguir realmente sair do lugar, aí você posta seu programa aqui e pergunta a sua dúvida.

Veja, até eu que tenho só a metade do cérebro consegui pelo menos chegar até a metade dos programinhas que eu fazia, quando surgia uma dúvida, eu colocava os bagaças mal feitas aqui e perguntava a minha dúvida pro pessoal que me davam dicas infalíveis.

E mais uma coisa meu anjo, o pessoal daqui do guj deteeeeeeesta quando alguém pedi pra eles fazerem os programas.

Se eles ficarem fazendo os programas dos outros, ninguém aprende nada.

Até mais fofa.

Fuiiiiiii.

"Não é o que somos, é o que podemos fazer!"
--------- The Lost Book of King Arthur ---------
void Edu{}
HelloWorld
[Avatar]

Membro desde: 26/09/2008 06:09:25
Mensagens: 11
Localização: Penha-SP
Offline

É fake

foi criado só pra zuar

pô laranjeira não avacalha o forum.....



Edu
gpd38
JavaEvangelist
[Avatar]

Membro desde: 17/03/2007 01:55:58
Mensagens: 414
Offline

Questão do vetor:



===============================================

1) Faça um programa para gerar n numero inteiros aleatorios e que imprima os numeros em ordem crescente.

2)Faça um programa para gerar n numero inteiros aleatorios e que imprima os numeros em ordem decrescente.


GERAR NUMERO ALEATORIO

A classe Math metodo Random() gera este numero pra vc, mas este numero gerado esta entre 0,0 e 1,0;
Vc deve trata-lo dependendo do seu uso.

Ex:
quero numeros entre 2,0 e 20,0

double aleatorio = 2 + ( Math.Random() * 20 );

Esta faixa de numeros esta entre 2,0 ate 20,0
Se quiser inteiro, coloca um cast ---> int valor = (int)(aleatorio);

IMPRIMIR EM ORDEM CRESCENTE E DECRESCENTE

Vc pode usar o mesmo metodo da bolha citado acima
so precisa mudar a condição de comparação .

2 opçoes
---> Cria 2 vetores diferentes e ordena cada um de um jeito: CRESCENTE e DECRESCENTE
ou
---> Cria um vetor ordena por exemplo crescente e imprime do inicio para o fim: CRESCENTE e do fim para o inicio DECRESCENTE

Ps.: Fica a sua escolha, usa o metodo da bolha citado acima.



Faça bom uso.
Acho que ja da para vc continuar sozinha daqui.

This message was edited 2 times. Last update was at 06/10/2008 01:41:26


Bacharel em Ciência da Computação
[WWW]
s4nchez
Virtual Machine Man
[Avatar]

Membro desde: 05/06/2006 11:35:55
Mensagens: 722
Localização: London, UK
Offline

Aproveita e dá uma olhada na classe Collections. Ela permite reordenar coleções facinho facinho...

Ivan Sanchez | coding dojo | blog | twitter
[WWW]
lgustavosic
Smalltalk

Membro desde: 21/05/2009 07:39:39
Mensagens: 4
Offline

Bom dia
Pessoal gostaria de uma ajuda ....
estou tentando ordenar um vetor em ordem crescente... e ao longo do algoritmo cheguei nisso



alguem poderia me ajudar em relação a isso ?
........................................................................
obrigado bom dia !

This message was edited 1 time. Last update was at 21/05/2009 08:48:32

lgustavosic
Smalltalk

Membro desde: 21/05/2009 07:39:39
Mensagens: 4
Offline

ops desculpa, esse eh o ultimo que tava elaborando !!

This message was edited 1 time. Last update was at 21/05/2009 08:48:43

lgustavosic
Smalltalk

Membro desde: 21/05/2009 07:39:39
Mensagens: 4
Offline

Ae pessoal, consegui fazer !!

segue abaixo codigo !!

algoritmo "semnome"
// Função :
// Autor :
// Data : 21/5/2009
// Seção de Declarações
var
vet:vetor[1..100]de inteiro
i,j,k,aux,qtd,l: inteiro
inicio
// Seção de Comandos
escreval("digite o a quantidade de numeros que tera seu vetor")
leia(qtd)
para i de 1 ate qtd faca
escreval("Digite o",i,"º numero")
leia(vet[i])
fimpara
para k de 1 ate i-1 faca
para j de 1 ate qtd faca
se vet[j] > vet[j+1] entao
aux := vet[j];
vet[j] := vet[j+1];
vet[j+1] := aux;
fimse

fimpara
fimpara
para l de 1 ate j faca
escreval(vet[l])
fimpara



fimalgoritmo
edipokbelo
JavaBaby
[Avatar]

Membro desde: 26/12/2008 08:56:33
Mensagens: 93
Offline

se você for usar array, faça assim:

This message was edited 1 time. Last update was at 21/05/2009 09:03:24

[Email] [MSN]
lgustavosic
Smalltalk

Membro desde: 21/05/2009 07:39:39
Mensagens: 4
Offline

A correto entendi !!

Muito Obrigado mesmo pela atenção !!!
Bom dia pra todo mundo !
 
Índice dos Fóruns » Java Básico
Ir para:   
Powered by JForum 2.1.8 © JForum Team