Algoritmos - MATRIZ E VETOR - Atualizado Explicação e Ajuda.  XML
Índice dos Fóruns » Java Básico
Autor Mensagem
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

Escreva um algoritmo para ler dois numeros quaisquer e imprimir o quadrado da diferença do primeiro pelo segundo e a diferença dos quadrados.


Galera a primeira parte eu consegui fazer ,mas a segunda eu não consigo entender ? e caso de interpreção ,alguem pode me orientar ?


algoritmo "Verificação de numeros "
// Função : Ler dois numeros e verificar se são diferentes
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var
x,y,z : real
inicio
escreva ("Escreva o valor de Y:"
leia (y)
escreva ("Escreva o valor de Z:"
leia (z)
x<-(y-z)
x<-x*x
escreval ("Diferença do quadrado " , x)
fimalgoritmo

Obs: Estou fazendo em portugues estruturado mesmo ,so para logica.

Valeu
[Email] [MSN]
diego2005
GUJ Master
[Avatar]

Membro desde: 17/08/2005 10:11:05
Mensagens: 1095
Offline

Você não entendeu a diferença dos quadrados???

Não seria:

x <- (y*y) - (z*z)


É isso a sua dúvida??

SCJP 1.4

Meu Currículo
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

Cara eu agradeço pacas ,porem a questão mesmo e , e possivel fazer essas duas coisas no mesmo algoritmos ,ou são algoritmos separados ?



- Escreva um algoritmo para ler dois numeros quaisquer e imprimir o quadrado da diferença do primeiro pelo segundo e a diferença dos quadrados.

Entendeu ? São duas situações

[Email] [MSN]
silvio.amaral
Smalltalk

Membro desde: 07/04/2007 22:00:10
Mensagens: 1
Offline

diria que a questão é resolvida assim:

declara x, y

inicio

x <- lernumero("entre com o primeiro numero")
y <- lernumero("entre com o segundo numero")

escreva ( "diferença dos quadrados: ", ((x^2) - (y^2)) )
escreva ( "quadrado da diferenca: ", ((x-y)^2) )

fim

Espero que ajude
sublyer
Debugger
[Avatar]

Membro desde: 19/06/2006 13:12:54
Mensagens: 74
Offline

Olá. bom tem uma coisa que não consegui entender... na parte que você diz "diferença dos quadrados." seria a diferença dos dois números elevados ao quadrado?
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

isso mesmo cara.

Não sabia aplicar os dois no mesmo algoritmo.
[Email] [MSN]
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

Galera me matei nos exercicios abaixo ,porem nao consigo fazer MATRIZ e VETOR ,alguma boa alma poderia corrigir os exercicios feitos e me ajudar nos 05 faltantes ?

Quem poder me ajudar agradeço pacas.


3. Ler dois números inteiros e imprimir uma mensagem dizendo se eles são iguais ou diferentes.

algoritmo "Verificação de numeros "
// Função : Ler dois numeros e verificar se são diferentes
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var
a,b : inteiro
inicio
escreva ("Escreva o valor de A:"
leia (a)
escreva ("Escreva o valor de B:"
leia (b)
se a=b entao
escreva ("Numeros iguais" )
senao
escreva ("Numeros diferentes"
fimse
fimalgoritmo



8. Entrar com o código do estado de uma pessoa e imprimir uma das mensagens conforme a informação abaixo.
carioca (código 100)
paulista (código 200)
mineiro (código 300)
outros estados para códigos diferentes dos citados acima


algoritmo "Còdigo de estado"
// Função : Verificar codigo correspondente ao estado
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var codigo : caracter
inicio
// Seção de Comandos
escreva("Entre com seu codigo:"
leia(codigo)
escolha codigo
caso "100"
escreva("Carioca"
caso "200"
escreva("Paulista"
caso "300"
escreva("Mineiro"
outrocaso
escreva("Outros Estados"
fimescolha
fimalgoritmo


13. Escreva um algoritmo para ler dois números quaisquer e imprimir o quadrado da diferença do primeiro pelo segundo e a diferença dos quadrados.


algoritmo "Quadrados - Diferenças"
// Função : Dois numeros quaisquer e imprimir o quadradro da diferença do 01º pelo 02º e dif dos quadrados.
// Autor : Allan James
// Data : 07/04/2007
// Seção de Declarações
var
a,b:inteiro
quadDif, difQuad:real
inicio
// Seção de Comandos
escreva("Digite um número:"
leia(a)
escreva("Digite um número:"
leia(b)
quadDif<- quad(a-b)
difQuad<- quad(a) - quad(b)
escreval("O quadrado da diferença é ",quadDif)
escreval("A diferença dos quadrados é ",difQuad)
fimalgoritmo



18. Construir um algoritmo que indique se o número digitado está compreendido entre 20 e 90 ou não.

algoritmo "Verificar numeros "
// Função : Ler dois numeros e verificar se estão entre 20 e 90 ou não
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var
a: inteiro
inicio
escreva ("Digite um valor "
leia (a)
se (a<90) e (a>20) entao
escreval (" O valor digitado está entre 20 e 90"
senao
escreval ("Valor não esta entre 20 e 90"
fimse
fimalgoritmo


23. Entrar com números enquanto forem positivos e pares e imprimir quantos números foram digitados.

algoritmo "Par ou ímpar "
// Função : Ler numeros e verificar se são par ou ímpares.
// Autor : Allan James
// Data : 07/04/2007
// Seção de Declarações

var
a, cont:inteiro
inicio
// Seção de Comandos
cont<-0
a<-1
escreval("Para sair digite 0"
enquanto (a>0) faca
escreva("Digite um numero:"
leia(A)
se a%2=0 entao
escreval ("É par"
cont<-cont+1
senao
escreval("É impar"
fimse
fimenquanto
escreva("Números pares:",cont)
fimalgoritmo



28. Fazer um algoritmo para ler um conjunto de 100 números reais (quaisquer) e informar:
? Quantos números lidos são iguais a 30.
? Quantos números são menores que a média.
? Quantos números são iguais a média.



33. Criar um algoritmo que leia os elementos de uma matriz inteira 10x10 e escreva os elementos acima da diagonal principal.



38. Entrar com valores inteiros para uma matriz A e B de ordem 4. Gerar e imprimir a matriz soma e matriz diferença.




43. Entre com valores em um vetor com 50 posições de inteiros. Logo após entre com um valor para fazer uma pesquisa dentro do vetor declarado. Ordene o vetor e depois aplique os conceitos de busca binária e responda:
? Se o elemento pesquisado existir imprima ?Encontrei na posição?, x.
? Se o elemento pesquisado não existir imprima ?Não existe o valor?, x.




48. Faça um programa que construa uma matriz quadrada de ordem 10 da seguinte forma. Na diagonal principal somente o valor 20. Acima da diagonal principal valores maiores que 20.
Abaixo da diagonal principal valores menores que 20. Faço o controle da quantidade de valores nos locais corretos.
[Email] [MSN]
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

allanfox wrote:Galera me matei nos exercicios abaixo ,porem nao consigo fazer MATRIZ e VETOR ,alguma boa alma poderia corrigir os exercicios feitos e me ajudar nos 05 faltantes ?

Quem poder me ajudar agradeço pacas.


3. Ler dois números inteiros e imprimir uma mensagem dizendo se eles são iguais ou diferentes.

algoritmo "Verificação de numeros "
// Função : Ler dois numeros e verificar se são diferentes
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var
a,b : inteiro
inicio
escreva ("Escreva o valor de A:"
leia (a)
escreva ("Escreva o valor de B:"
leia (b)
se a=b entao
escreva ("Numeros iguais" )
senao
escreva ("Numeros diferentes"
fimse
fimalgoritmo



8. Entrar com o código do estado de uma pessoa e imprimir uma das mensagens conforme a informação abaixo.
carioca (código 100)
paulista (código 200)
mineiro (código 300)
outros estados para códigos diferentes dos citados acima


algoritmo "Còdigo de estado"
// Função : Verificar codigo correspondente ao estado
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var codigo : caracter
inicio
// Seção de Comandos
escreva("Entre com seu codigo:"
leia(codigo)
escolha codigo
caso "100"
escreva("Carioca"
caso "200"
escreva("Paulista"
caso "300"
escreva("Mineiro"
outrocaso
escreva("Outros Estados"
fimescolha
fimalgoritmo


13. Escreva um algoritmo para ler dois números quaisquer e imprimir o quadrado da diferença do primeiro pelo segundo e a diferença dos quadrados.


algoritmo "Quadrados - Diferenças"
// Função : Dois numeros quaisquer e imprimir o quadradro da diferença do 01º pelo 02º e dif dos quadrados.
// Autor : Allan James
// Data : 07/04/2007
// Seção de Declarações
var
a,b:inteiro
quadDif, difQuad:real
inicio
// Seção de Comandos
escreva("Digite um número:"
leia(a)
escreva("Digite um número:"
leia(b)
quadDif<- quad(a-b)
difQuad<- quad(a) - quad(b)
escreval("O quadrado da diferença é ",quadDif)
escreval("A diferença dos quadrados é ",difQuad)
fimalgoritmo



18. Construir um algoritmo que indique se o número digitado está compreendido entre 20 e 90 ou não.

algoritmo "Verificar numeros "
// Função : Ler dois numeros e verificar se estão entre 20 e 90 ou não
// Autor : Allan James
// Data : 31/03/2007
// Seção de Declarações
var
a: inteiro
inicio
escreva ("Digite um valor "
leia (a)
se (a<90) e (a>20) entao
escreval (" O valor digitado está entre 20 e 90"
senao
escreval ("Valor não esta entre 20 e 90"
fimse
fimalgoritmo


23. Entrar com números enquanto forem positivos e pares e imprimir quantos números foram digitados.

algoritmo "Par ou ímpar "
// Função : Ler numeros e verificar se são par ou ímpares.
// Autor : Allan James
// Data : 07/04/2007
// Seção de Declarações

var
a, cont:inteiro
inicio
// Seção de Comandos
cont<-0
a<-1
escreval("Para sair digite 0"
enquanto (a>0) faca
escreva("Digite um numero:"
leia(A)
se a%2=0 entao
escreval ("É par"
cont<-cont+1
senao
escreval("É impar"
fimse
fimenquanto
escreva("Números pares:",cont)
fimalgoritmo



28. Fazer um algoritmo para ler um conjunto de 100 números reais (quaisquer) e informar:
? Quantos números lidos são iguais a 30.
? Quantos números são menores que a média.
? Quantos números são iguais a média.



33. Criar um algoritmo que leia os elementos de uma matriz inteira 10x10 e escreva os elementos acima da diagonal principal.



38. Entrar com valores inteiros para uma matriz A e B de ordem 4. Gerar e imprimir a matriz soma e matriz diferença.




43. Entre com valores em um vetor com 50 posições de inteiros. Logo após entre com um valor para fazer uma pesquisa dentro do vetor declarado. Ordene o vetor e depois aplique os conceitos de busca binária e responda:
? Se o elemento pesquisado existir imprima ?Encontrei na posição?, x.
? Se o elemento pesquisado não existir imprima ?Não existe o valor?, x.




48. Faça um programa que construa uma matriz quadrada de ordem 10 da seguinte forma. Na diagonal principal somente o valor 20. Acima da diagonal principal valores maiores que 20.
Abaixo da diagonal principal valores menores que 20. Faço o controle da quantidade de valores nos locais corretos.



E ai galera alguem pode ajudar ou ao menos indicar algum forum ou area mais adequado ?
[Email] [MSN]
allanfox
JavaBaby

Membro desde: 24/08/2006 09:53:53
Mensagens: 96
Localização: São Paulo
Offline

28-Fazer um algoritmo para ler um conjunto de 100 numeros reais (quaisquer) e informar.
-Quantos numeros lidos sao iguais a 30.
-Quantos numeros sao menores que a media.
-Quantos numeros sao iguais a media.


Obs: Falta so 4 exer tá fogo.


real vetor[100]; // declarei um vetor de 100 numeros reais

real numeroASerContado = 30;
inteiro totalDeNumeros = 100;

real somatorio = 0;
inteiro contador = 0;
inteiro contadorDeNumero = 0;

enquanto(contador < totalDeNumeros) {
// preenchendo o vetor com numeros aleatorios
vetor[contador] = numeroRealAleatorio();

somatorio = somatorio + vetor[contador];

se(vetor[contador] == numeroASerContado) {
contadorDeNumero = contadorDeNumero + 1;
}

contador = contador + 1;
}

real media = somatorio / totalDeNumeros; /* media aritimetica */

contador = 0;
inteiro contadorDeIguaisAMedia = 0;
inteiro contadorDeMenoresQueAMedia = 0;

equanto(contador < totalDeNumeros) {
se (vetor[contador] == media) {
contadorDeIguaisAMedia = contadorDeIguaisAMedia + 1;
} senão se (vetor[contador] < media) {
contadorDeMenoresQueAMedia = contadorDeMenoresQueAMedia + 1;
}

contador = contador + 1;
}

escreva("Numeros iguais a " + numeroASerContado + " == " + contadorDeNumero);

escreva("Numeros menores que a media == " + contadorDeMenoresQueAMedia);

escreva("Numeros iguais a media == " + contadorDeIguaisAMedia);
[Email] [MSN]
hebertfalcao
Smalltalk
[Avatar]

Membro desde: 16/08/2008 23:11:20
Mensagens: 1
Localização: cuiaba
Offline

allanfox wrote:28-Fazer um algoritmo para ler um conjunto de 100 numeros reais (quaisquer) e informar.
-Quantos numeros lidos sao iguais a 30.
-Quantos numeros sao menores que a media.
-Quantos numeros sao iguais a media.


Obs: Falta so 4 exer tá fogo.


real vetor[100]; // declarei um vetor de 100 numeros reais

real numeroASerContado = 30;
inteiro totalDeNumeros = 100;

real somatorio = 0;
inteiro contador = 0;
inteiro contadorDeNumero = 0;

enquanto(contador < totalDeNumeros) {
// preenchendo o vetor com numeros aleatorios
vetor[contador] = numeroRealAleatorio();

somatorio = somatorio + vetor[contador];

se(vetor[contador] == numeroASerContado) {
contadorDeNumero = contadorDeNumero + 1;
}

contador = contador + 1;
}

real media = somatorio / totalDeNumeros; /* media aritimetica */

contador = 0;
inteiro contadorDeIguaisAMedia = 0;
inteiro contadorDeMenoresQueAMedia = 0;

equanto(contador < totalDeNumeros) {
se (vetor[contador] == media) {
contadorDeIguaisAMedia = contadorDeIguaisAMedia + 1;
} senão se (vetor[contador] < media) {
contadorDeMenoresQueAMedia = contadorDeMenoresQueAMedia + 1;
}

contador = contador + 1;
}

escreva("Numeros iguais a " + numeroASerContado + " == " + contadorDeNumero);

escreva("Numeros menores que a media == " + contadorDeMenoresQueAMedia);

escreva("Numeros iguais a media == " + contadorDeIguaisAMedia);

valeu muito obrigado!
[WWW] [Yahoo!] [MSN]
 
Índice dos Fóruns » Java Básico
Ir para:   
Powered by JForum 2.1.8 © JForum Team