GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

App parou de responder

error
android
Tags: #<Tag:0x00007fb791e1f5a0> #<Tag:0x00007fb791e1f3e8>

#1

Olá, é minha primeira vez aqui no site e meio que estou em uma situação complicada no meu TCC, a tempos estou usando o livro do Nelson Glauber para aprender sobre a tecnologia android. Indo ao que interessa, após alguns programas rodando perfeitamente eis que me aconteceu o seguinte. Nenhum porgrama roda mais. todos, ao serem compilados e instalados no meu celular(testei em 3 celulares e na Virtual Machine) e nenhum dá certo. Todos aparecem :open_mouth: app Teste12 parou de funcionar.
Alguém de vocês já passou por isso? Sabem se pode ser algo na Activity? Obrigado de verdade


#2

Não entendo absolutamente nada de programação de aplicativos para Android, nunca fui atrás. Porém, algo me diz que ninguém vai saber diagnosticar o teu problema a partir de tão pouca informação. Pensando nisso, acho melhor você dar uma melhorada na tua pergunta, provendo detalhes mais específicos, pois é o que as pessoas vão te perguntar para poder te ajudar. Não me entenda mal, por favor. Apesar de parecer ser suficiente, tua descrição do problema está extremamente vaga, é praticamente impossível descobrir sem investigar um pouco.

Para isso que servem os logs. A ideia é que sempre a causa do problema apareça lá. Seja no do runtime ("real" ou simulado), seja no do compilador, seja no da IDE. É a forma mais rápida de se chegar a causa real do problema. Posta um stack trace que a galera vai poder ler e te dar a resposta na lata, sem enrolação!


#3

Entendo o que quis dizer amigo, e agradeço, mas esse é o problema, não tenho a menor idéia do que acontece com os apps desenvolvidos. Acontece assim, eu desenvolvo, aparentemente está tudo normal na questão da codificação, mas, na hora de ser reproduzido no celular, ou na VM, ele para de funcionar, estou estudando possíveis erros na hora da criação da Activity, por está estar sendo criada com obejtos a mais(já dizia um professor: se algo aparece, apenas deletar não funciona).Enfim, estou na luta, mas obrigado pelo conselho.Abraços


#4

Tenta encontrar para onde vão os logs de erro de runtime da tua aplicação no simulador. Geralmente é gerado um arquivo com os problemas.

Tenta debugar pela IDE também, coloca pra executar e vai mexendo até travar para ver o que aparece no log dela.


#5

A aplicação abre ? A aplicação funciona mais em determinado ponto ela para ? A aplicação para quando o usuário insere uma entrada ?
O seu problema pode está relacionado com a criação da activity, ou alguma coisa relacionada a IDE já pensou nisso ?

Se possível posta código, posta print, coloca um pouco mais de informação mano :smiley: