GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

Baixar J2SE + J2EE


#1

Onde baixo, no site da Sun, o J2SDK 1.4.1 COMPLETO??

Queria o pacote (se é que existe), com TODOS os pacotes disponíveis de todas as Tecnologias Java!

É que baixei o J2SDK 1.4.1 de mais ou menos 38Mb e ele só contém os pacos do J2SE e não do J2EE! Se quero rodar os meus servlets e JSPs, tenho que baixar do site da Sun o pacote J2EE!

Será que num existem algum PACOTÃO com todas as classes juntas não, para eu instalar de uma só vez??

Um colega meu falou que existia, mas procurei e NADA!


#2

Pelo que entendí o J2EE que vc está falando é o J2sdkee. Na verdade para rodar servlets e JSP vc só precisa do j2sdk e um web container tal como o tomcat do projeto jakarta. O J2sdkee é quando vc precisa trabalhar em ambiente distribuído.

A respeito de um "pacotão com tudo", provavelmente vc não encontrará, pois tem diversos projetos (Open-Source, comerciais, etc) de diversos fabricantes. Além disso seria inviável, pois ficaria muito grande, uma vez que temos um monte de bibliotecas de classes, para diversas finalidades para o mundo java.

[]s, Welington B. Souza


#3

É isso mesmo...tô falando do J2SDKEE!

Baixei o J2SDK, mas os servlets não compilam por ele! Tenho que acrescentar na IDE que uso (Eclipse), os .JAR do J2SDKEE para poder os servlets compilarem! Será que tô fazendo algo de errado??

O J2SDK já vem com os pacotes javax.servlet e javax.servlet.http ???

[]'s Tjmm.


#4

Como eu disse, vc nao precisa do j2sdkee, vc vai precisar de um software chamado web container. Existem diversos tanto open-source como pagos. O jakarta project tem um web container muito popular, free, sob a apache license. Trata-se do Tomcat. É um dos mais usados no mundo. Vc deverá baixar os binários em http://jakarta.apache.org/tomcat/index.html, instalar e setar as variaveis de ambiente dentro do eclipse para as libs do tomcat e começar a fazer as suas servlets e jsps.

[]s, Welington B. Souza


#5

Não cara...do Tomcat eu sei que precisa e inclusive já fiz uns testes com ele! Quero saber dos pacotes javax.servlet e javax.servlet.http! Esses pacotes vem junto com o J2SDK 1.4.1?? É isso que quero saber!

Porque quando crio o meu servlet e vou compilar, o compilador reclama que não consegue encontrar as linhas que importo esses pacotes! É isso que quero saber...!

Porque se não me engano o J2SDK 1.4.1 é o J2SE e NÃO vem com os .class das classes desses pacotes!

O que eu quero saber é ONDE encontrar um Kit de Desenvolvimento, como o JDK que já venha com os pacotes javax.servlet e javax.servlet.http?? Tenho que baixar o J2SDKEE ??

[]'s Tjmm.


#6

Up...


#7

O J2EE vem sim, no j2ee.jar, mas você não precisa obrigatoriamente dele, pois no diretório common/lib do Tomcat tem o servlet.jar, que também contém essas classes.


#8