Angular servidor e jenkins

Jenkins

+ npm install
npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!
npm WARN @agm/core@1.1.0 requires a peer of @angular/common@^6.0.0 || ^7.0.0 || ^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @agm/core@1.1.0 requires a peer of @angular/core@^6.0.0 || ^7.0.0 || ^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular-material-components/datetime-picker@5.0.3 requires a peer of @angular/material@^11.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN @angular-material-components/datetime-picker@5.0.3 requires a peer of @angular/cdk@^11.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/flex-layout@10.0.0-beta.32 requires a peer of @angular/cdk@^10.0.0-rc.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ngrx/effects@8.6.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ngrx/router-store@8.6.0 requires a peer of @angular/common@^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ngrx/router-store@8.6.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ngrx/router-store@8.6.0 requires a peer of @angular/router@^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ngrx/store@8.6.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-dnd@8.2.0 requires a peer of @angular/common@^8.0.0 || ^9.0.0 || ^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @swimlane/ngx-dnd@8.2.0 requires a peer of @angular/core@^8.0.0 || ^9.0.0 || ^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN bootstrap@4.6.0 requires a peer of popper.js@^1.16.1 but none is installed. You must install peer dependencies yourself.
npm WARN @devextreme/runtime@2.3.14 requires a peer of vue@^2.6.14 but none is installed. You must install peer dependencies yourself.
npm WARN icss-utils@5.1.0 requires a peer of postcss@^8.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-cookie-service@10.1.1 requires a peer of @angular/common@^10.0.5 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-cookie-service@10.1.1 requires a peer of @angular/core@^10.0.5 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-material-file-input@2.1.1 requires a peer of @angular/cdk@^8.1.1 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-material-file-input@2.1.1 requires a peer of @angular/common@^8.1.3 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-material-file-input@2.1.1 requires a peer of @angular/core@^8.1.3 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-material-file-input@2.1.1 requires a peer of @angular/material@^8.1.1 || ^9.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-material-file-input@2.1.1 requires a peer of tslib@^1.10.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-webstorage@6.0.0 requires a peer of @angular/common@^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ngx-webstorage@6.0.0 requires a peer of @angular/core@^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN postcss-modules-extract-imports@3.0.0 requires a peer of postcss@^8.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN postcss-modules-local-by-default@4.0.0 requires a peer of postcss@^8.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN postcss-modules-scope@3.0.0 requires a peer of postcss@^8.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN postcss-modules-values@4.0.0 requires a peer of postcss@^8.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN primeng@11.0.0-rc.2 requires a peer of @angular/core@^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN primeng@11.0.0-rc.2 requires a peer of @angular/common@^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN primeng@11.0.0-rc.2 requires a peer of @angular/forms@^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/@angular/compiler-cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/karma/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/rollup/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/watchpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

removed 1 package and audited 1794 packages in 14.916s

89 packages are looking for funding
  run `npm fund` for details

found 197 vulnerabilities (2 low, 97 moderate, 87 high, 11 critical)
  run `npm audit fix` to fix them, or `npm audit` for details
+ ng build --prod --c=hom --base-href=/comprasfood_frontend/
- Generating browser application bundles...

<--- Last few GCs --->

[15617:0x4e1aba0]   206579 ms: Mark-sweep (reduce) 990.7 (999.3) -> 990.4 (1001.0) MB, 1987.4 / 0.1 ms  (average mu = 0.079, current mu = 0.003) allocation failure scavenge might not succeed
[15617:0x4e1aba0]   208405 ms: Mark-sweep (reduce) 991.4 (1003.0) -> 991.0 (1003.8) MB, 1821.9 / 0.1 ms  (average mu = 0.044, current mu = 0.003) allocation failure scavenge might not succeed


<--- JS stacktrace --->

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory
 1: 0xa03530 node::Abort() [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 2: 0x94e471 node::FatalError(char const*, char const*) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 3: 0xb7773e v8::Utils::ReportOOMFailure(v8::internal::Isolate*, char const*, bool) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 4: 0xb77ab7 v8::internal::V8::FatalProcessOutOfMemory(v8::internal::Isolate*, char const*, bool) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 5: 0xd32345  [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 6: 0xd32ecf  [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 7: 0xd40f5b v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 8: 0xd44b1c v8::internal::Heap::AllocateRawWithRetryOrFailSlowPath(int, v8::internal::AllocationType, v8::internal::AllocationOrigin, v8::internal::AllocationAlignment) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
 9: 0xd131fb v8::internal::Factory::NewFillerObject(int, bool, v8::internal::AllocationType, v8::internal::AllocationOrigin) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
10: 0x105919f v8::internal::Runtime_AllocateInYoungGeneration(int, unsigned long*, v8::internal::Isolate*) [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
11: 0x13ff179  [ng build --prod --c=hom --base-href=/comprasfood_frontend/]
Aborted (core dumped)
[Pipeline] }
Failed to update Gitlab commit status for project '16': RESTEASY004655: Unable to invoke request
[Pipeline] // gitlabCommitStatus
[Pipeline] }
[Pipeline] // script
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (NOTIFY FAILED)
[Pipeline] updateGitlabCommitStatus
[Pipeline] }
[Pipeline] // stage
[Pipeline] }
[Pipeline] // node
[Pipeline] End of Pipeline
ERROR: script returned exit code 134
Finished: FAILURE

Como faço para resolver ?

O problema s√£o estas duas depedencias no angular

"exceljs": "^4.3.0",
"file-saver-es": "^2.0.5",

Tirei e funcionou

1 curtida