GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

Comparar duas colunas e retornar a soma

office
tabelas
excel
comparação
Tags: #<Tag:0x00007f6106f6f040> #<Tag:0x00007f6106f6eed8> #<Tag:0x00007f6106f6ec80> #<Tag:0x00007f6106f6eac8>
#1

Fala pessoal,

Tenho a seguinte tabela abaixo, o que eu quero fazer é somar os “Preços” dos livros cuja situação está como “Vendido”. Eu quero que o resultado da soma dos itens que eu marquei como “Vendido” apareça na célula E23, ali onde está o número “4”.

Sei que dá para fazer com a função PROCV. Já estou a horas, estudando essa função e até agora eu não consegui aplicar na minha tabela. Se alguém puder me ajudar, ficarei extremamente grato.

No mais, agradeço a atenção e compreensão do problema.

Capturar

0 Likes

#2

Fala ai @AlanMSV, cara vc poderia resolver esse impasse utilizando a função SOMASE do excel. Basicamnete a logica dela é apenas somar os valores das colunas indicadas caso um determinado valor seja verdadeiro. No seu caso na celula E23 voce colocaria

=SOMASE(E2:E22;“Vendido”;D2:D22)

Analisando a função ele pega o intervalo E2 ate E22 e compara cada valor com “Vendido”, caso o valor seja igual ele inclui no somatorio a coluna correspondente do intervalo D2 ate D22.

Llink para Melhores esclarecimentos sobre o SOMASE
https://support.office.com/pt-br/article/somase-fun%C3%A7%C3%A3o-somase-169b8c99-c05c-4483-a712-1697a653039b

Abração
Max

1 Like