Exercício Triângulo algoritmo  XML
Índice dos Fóruns » Java Básico
Autor Mensagem
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

Estou tento uma certa dificuldade de passa um exercício que resolvi em portunhol por entender somente um pouco de java.
quem poder me ajudar ficaria muito agradecido, irei passa o algoritmo resolvido por mim.

inicio
inteiro A, B, C;
leia (A, B, C);
se ((A < B = C) E (B < A + C) E (C < A + B))
então
se ((A =B) E (B = C))
então
escreva ("Triangulo Equilátero);
senão
se ((A = B) OU (A = C) OU (B = C)
então
escreva ("Triângulo Isósceles");
senão
escreva ("Triângulo Escaleno");
fimse;
fimse;
senão
escreva ("Estes valores não formam um triângulo");
fimse;
fim.

eu uso NetBeans e estou tendo um certo dificuldade em executar o
if (( A < B + C) AND (B < A + C) AND (C < A +B))

talvez seja porque sou iniciante mesmo na linguagem, mas alguém poderia me mostra como ficaria em algoritmo em java?

Obrigado
wbdsjunior
GUJ Ranger
[Avatar]

Membro desde: 16/04/2008 13:48:08
Mensagens: 992
Localização: Indaiatuba/SP
Offline


She loves me

http://lmgtfy.com
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

ta certo fiz tudo que você falou deu certo sim cara, mas como disse sou iniciante na linguagem dai eu coloquei logo assim e deu errado


deu erro no segundo IF, e mais uma duvida como ficaria OR aqui em java?

Obrigado

pmlm
GUJ Master

Membro desde: 20/04/2009 12:20:07
Mensagens: 1700
Localização: Portugal
Offline

A comparação em JAVA é com ==



O simbolo de OR é ||
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

certo vamos la novamente, eu troquei o AND por && certo?
agora coloquei OR e deu erro no meu condigo!

com base no meu primeiro algoritmo em portugol, ele estaria ficando assim!


ressaltando estou usando NetBeans.
onde eu coloquei o ELSE esta correto?
e o OR aqui não esta funcionando.

Obrigado.
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

desculpe a ignorância agora que eu vi o OR é ||
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

É agora o erro só esta sendo acho na organização do algoritmo.
quando executei meu programa coloquei o primeiro dado que era pra aparecer "Triângulo Equilátero" até ai tudo bem, ja quando fui executar o segundo "Triângulo Isósceles" ele não apareceu, seria por causa do ELSE estar em lugar errado?

alguém poderia me da uma ajuda nessa parte?

Obrigado
Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline

Obrigado Pessoal, meu problema ja foi resolvido

E agradeço pela a ajuda de cada um.

Obrigado
Jadir
Milk15
Debugger
[Avatar]

Membro desde: 25/10/2010 11:57:01
Mensagens: 56
Offline

mostre seu código aqui pra gente ver como tá

Edit: Tópico resolvido então rs

This message was edited 1 time. Last update was at 02/05/2011 11:28:07

Jadir
Debugger

Membro desde: 15/03/2011 22:47:25
Mensagens: 66
Offline



fiz em modo construtor porque ja aprendi a fazer desse jeito, e como faz coloca tópico resolvido, não entendi muito bem o que você falou!

montanha007
Entusiasta Java
[Avatar]

Membro desde: 24/02/2011 12:50:46
Mensagens: 19
Localização: Goiânia
Offline

Só irá existir um triângulo se, somente se, os seus lados obedeceram à seguinte regra: um de seus lados deve ser maior que o valor absoluto (módulo) da diferença dos outros dois lados e menor que a soma dos outros dois lados.


This message was edited 1 time. Last update was at 02/05/2011 12:04:09


Rumo a OCJP
[MSN]
 
Índice dos Fóruns » Java Básico
Ir para:   
Powered by JForum 2.1.8 © JForum Team