Ajax4JSF com RichFaces gera o erro A4J is not defined

Estou implementando uma funcionalidade Ajax em meu projeto com JSF 1.2 e RichFaces 3.2.2, Faço um SelectOneMenu que atualiza outro select no onchange através do <a4J:suport . Bem, funciona tudo certinho no meu computador, mas quando faço deploy no servidor o ajax nao funciona o o firebug apresenta um erro chamado “A4J is not defined”. O pessoal do servidor me garantiu que a configuração está correta e eu já veririquei tab que todas as JARs sao adicionadas à pasta LIB.
Alguem já se deparou com este problema?

Veja o problema que ocorre acessando www.doctorauto.com.br/testeAjax

Alguem conseguiu resolver este problema ? Estou enfrentando ele e não sonsegui solução.

Você conseguiu resolver este problema Rogério? Ou alguem ?

Tente fazer isso para resolver o problema

Troque a seguinte linha:

<%@ taglib uri=“http://richfaces.org/a4j” prefix=“a4j”%>

Por

<%@ taglib uri=“https://ajax4jsf.dev.java.net/ajax” prefix=“a4j”%>

E depois diga se funcionou

Abraços

rodcesar ,

Eu estou com o mesmo problema. Eu mudei a taglib como você falou e não funcionou, continuou na mesma.

Aqui na empresa estamos usando uma estrutura de shared Library e o cliente pede que os jars do RichFaces estejam no shared library. Para as tags funcionarem eu tive que pegar as tlds dentro do RichFaces e coloquei em um jar dentro do WEB-INF/lib (isto é uma recomendação na especificação do J2EE).

Se eu pegar os jars do richfaces e colocar no lib da aplicação, ai na hora de subir o servidor, dá um erro com o Digester.

Tem alguma ideia ?

Obrigado