[Ajuda] - problema de Codificação de string de um xml no flex

Olá galera!
estou com o seguinte problema
eu pego uma string parecida como essa de um xml:
ny|uDdz{|I_xEw_@mfGbe@s|AgFunHaoEglGgfI}u@ e por ai vai.
quando eu pego ela e mostro em um alert ela vem OK igualzinha como no xml.
porém qdo pego e jogo dentro de uma string do AS e coloco essa string em uma funcao onde utilizo-a parece que a mesma fica codificada diferente do xml.
Já quando atribuo na mão o valor para essa string e coloco a mesma na funcao funciona corretamente.
alguem ja passou por isso?

for (var i:int = 0; i < 27; i++){
    		if (((cmbEstado.selectedItem as Estado).nome).toLowerCase() == 
  			(servicoContornoEstado.lastResult.Document.estado[i].nome)){
                                //Dessa forma funciona corretamente e desenha tudo corretamente
  				var pontos:String = "ny|uDdz{|I_xEw_@mfGbe@s| .. e por ai vai a string ; 
                                 
                                //porém fazendo dessa forma os dados vem corretamente do xml porém qdo jogo na string nao faz o que deveria fazer corretamente
  				var pontos:String = (servicoContornoEstado.lastResult.Document.estado[i].pontos); 
								
                                //os levels não possuem acento nem caracteres especiais como os pontos por isso nao da problema algum
  				var levels:String = (servicoContornoEstado.lastResult.Document.estado[i].levels);
  				  				
  				encodedPolyline = Polyline.fromEncoded(
    				new EncodedPolylineData(pontos, 2, levels, 18), 
    				new PolylineOptions({ 
    					strokeStyle: new StrokeStyle({
        					color: 0x0000ff,
        					thickness: 2,        		
        					alpha: 0.7       		
        				})
    				})
    			);
    			//Alert.show(pontos);    			    			
    			map.addOverlay(encodedPolyline);  

Já tentei usar vários tipos de codificação do xml mas o problema é sempre qdo vou atribuir os valores do xml para a string. E se coloco direto na funcao o resultado do xml também acontece a mesma coisa
alguém?