Erro ao Instalar o tomcat no Ubuntu 9.10

Bom dia, pessoall.

Tenho o ubuntu 64 e estou tentando instalar o tomacat 6 na hora de
iniciar acusa o seguinte erro:

Neither the JAVA_HOME nor the JRE_HOME environment variable is defined
At least one of these environment variable is needed to run this program

Entretanto já criei estas variavéis o comando java -version perfeitamente.
Abaixo meu arquivo de configuração:

# System-wide .bashrc file for interactive bash(1) shells.

# To enable the settings / commands in this file for login shells as well,
# this file has to be sourced in /etc/profile.

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, overwrite the one in /etc/profile)
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '

# Commented out, don't overwrite xterm -T "title" -n "icontitle" by default.
# If this is an xterm set the title to user@host:dir
#case "$TERM" in
#xterm*|rxvt*)
#    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
#    ;;
#*)
#    ;;
#esac

# enable bash completion in interactive shells
#if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
#    . /etc/bash_completion
#fi

# sudo hint
if [ ! -e $HOME/.sudo_as_admin_successful ]; then
    case " $(groups) " in *\ admin\ *)
    if [ -x /usr/bin/sudo ]; then
	cat <<-EOF
	To run a command as administrator (user "root"), use "sudo <command>".
	See "man sudo_root" for details.
	
	EOF
    fi
    esac
fi

# if the command-not-found package is installed, use it
if [ -x /usr/lib/command-not-found ]; then
	function command_not_found_handle {
	        # check because c-n-f could've been removed in the meantime
                if [ -x /usr/lib/command-not-found ]; then
		   /usr/bin/python /usr/lib/command-not-found -- $1
                   return $?
		else
		   return 127
		fi
	}
fi
export JAVA_HOME=/opt/jdk-64/jdk1.6.0_17/bin
export PATH=:/opt/jdk-64/jdk1.6.0_17/bin:$PATH 
export CATALINA_HOME=:/opt/apache-tomcat-6.0.20
#export JRE_HOME=:/opt/jdk-64/jdk1.6.0_17/jre



#JAVA_HOME=/opt/jdk-64/jdk1.6.0_17/bin/java 
#export JAVA_HOME
#CLASSPATH=.:$JAVA_HOME/lib/tools.jar
#PATH=$JAVA_HOME/bin:$PATH
#export JAVA_HOME CLASSPATH PATH 

Já dei chmod em todos os arquivos da pagina do tomcat, sem sucesso.
Agradeço qualquer sugestão.

Você instalou o Tomcat que vem no Synaptic ou baixou na mão?

Se instalou o do Synaptic, o serviço do Tomcat é iniciado no boot do Linux. O próprio Synaptic configura isso.

No meu Ubuntu eu tenho as duas situações, mas desabilitei o serviço automático. Quando rodo na mão ele está OK, sem problema nenhum.

No seu caso não sei o que pode ser. Talvez tente o seguinte comando, para apontar qual o JDK padrão do seu Linux:

update-alternatives --config java