Java class version - porfavor, me ajudem!

Olá pessoal,

Como eu faço pra mudar a versão das minhas classes?
no meu pc tá gerando 49… na locaweb (onde tá minha aplicação) tá 48!

alguem pode me ajudar?

um abraço

Olá…

Procure compilar suas classes usando javac com a diretiva -source especificando a versão 1.4 para que ela possa ser suportada no servidor de destino.

Pelo que constato, você tem suas aplicações rodando em Java 5.0 porém a versão do JDK do servidor é 1.4. A outra alternativa que você pode tomar é verificar com eles a possibilidade da sua aplicação ser migrada para a versão 5.0 do java, que eles já trabalham com isso.

Espero ter ajudado.

Andy.