GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

JAVA INSTALACAO - Erro de incompatibilidade

JAVA INSTALAÇÃO – ECLIPSE

Olá Pessoal, estou com dificuldade de instalar e configurar o IDE para Java.

Basicamente a instalação foi tranquila, usei o instalação eclipse-inst-win64 .

Executei e instalei os Plug-ins - http://dl.google.com/eclipse/inst/d2wbpro/latest/3.7.

No momento em que vou fazer um teste, por exemplo, JFrame , e ir na guia Design , apresenta um erro de incompatibilidade.

Eclipse is running under 0, but this Java project has a 13 Java compliance level, so WindowBuilder will not be able to load classes from this project. Use a lower level of Java for the project, or run Eclipse using a newer Java version.

Obrigado!
Marcelo Tadeu

Mais prático: Usa o Java 8. Ou siga essa dica sobre alterar o nível de conformidade pra 1.8: https://stackoverflow.com/questions/51408029/incompatible-java-versions-for-windowbuilder

E’ bem tranquilo programar e usar Java >= 9, mas tem que ser modular, no entanto se o seu projeto for anterior ao Java 9 nao sendo modular nao tem problema, sera modular automatico, mas tem que carregar na chamada os modulos necessarios.

Da’ uma olhada na documentacao Java modular.

E sim vale a pena usar o Java 9 ou superior, sao muitos os recursos entre eles, carregamento mais rapido, menos memoria, mais seguro ainda e por ai vai.

Obrigado Pela Dica ! Funcionou.

Vamos ver agora o que vem pela frente.

1 Curtida
//