GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

AJUDA nesse exercicio de algoritmo para mostrar as medias

Olá pessoal, estou estudando algoritmos e estou fazendo exercicios em portugol, porem esta bugado na hora de mostrar a media de cada aluno (to fazendo um exercicios com correção de gabaritos), segue o codigo.

var
val: vetor[1…5] de caractere
resp: vetor[1…5] de caractere
num: inteiro
nome: vetor[1…3] de caractere
nota: vetor[1…3] de real
notafinal: real

inicio
EscrevaL(“Gabarito das questões”)
EscrevaL("----------------------")
para num de 1 ate 5 faca
Escreva(“Questão”, num, ": ")
Leia(val[num])
fimpara

limpatela

     para num de 1 ate 3 faca

notafinal <- 0
EscrevaL("----------------------")
EscrevaL(“Aluno”, num)
EscrevaL("----------------------")
EscrevaL("Nome: ")
Leia(nome[num])

           EscrevaL("RESPOSTAS DADAS")
                Para num de 1 ate 5 faca
                Escreva("Questao", num, ": ")
                Leia(resp[num])
                               Se val[num] = resp[num] entao
                               notafinal <- notafinal + 2
                               fimse
                 fimpara

para num de 1 ate 3 faca
nota[num] <- notafinal
fimpara
limpatela
fimpara

limpatela

EscrevaL(“NOTAS FINAIS “)
EscrevaL(”-----------------------------”)
Para num <- 1 ate 3 faca
EscrevaL(nome[num]:10, nota[num]:4:1)
FimPara

fimalgoritmo

//