GUJ Discussões   :   últimos tópicos   |   categorias   |   GUJ Respostas

Preciso de ajuda com matrizes

Algoritmo "matrizes"

Var

   mat: vetor [1..4,1..4] de real
   vet: vetor [1..4,1..4] de real
   c, l, n, j: inteiro

Inicio

      para l de 1 ate 4 faca
        para c de 1 ate 4 faca
            escreval("De um valor para a linha ", l, " e coluna ", c)
            leia(mat[l,c])
        fimpara
      fimpara
      
      para l de 1 ate 4 faca
        para c de 1 ate 4 faca
          se(mat[l,c] > 10)entao
            n <- n + 1
            vet[j] <- mat[l,c]
          fimse
        fimpara
      fimpara

      para j de 1 ate n faca
          escreva(vet[j], " ")
      fimpara

Fimalgoritmo

estava tentando fazer um programa que alguem daria valores para um matriz 4x4, e tinha conferir os numeros maiores que 10 e guardar em uma vetor. porem fica dando um erro “vet[0] nao existe”

//